npm dependencies?

  • Författare
  • Meddelande

theEmelie

html-guru

  • Inlägg: 62
  • Blev medlem: 02 sep 2018, 20:06

npm dependencies?

Inlägg13 sep 2019, 01:50

Jag laddade upp min uppgift för ramverk till github där jag använder react och fick ganska många "Security Alerts" och det verkar ha att gör med att uppdatera npm dependencies? Mitt projekt fungerar helt okej men det känns som om det här kanske borde fixas.

Det första "Security Alerts" är odash.template - critical severity

Jag får meddelanden som dessa när jag försöker uppdatera

Kod: Markera allt
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules\react-scripts\node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})


Kod: Markera allt
npm WARN rollback Rolling back node-pre-gyp@0.12.0 failed (this is probably harmless): EPERM: operation not permitted, lstat 'C:\cygwin64\home\Emelie\jsramverk\me-react\node_modules\fsevents\node_modules'

DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})


Jag testade även att ta bort node_moduls och package-lock.json och fick då detta meddelandet när jag körde npm install:
Kod: Markera allt
$ npm install
npm WARN deprecated fsevents@1.2.4: Way too old
npm WARN deprecated core-js@2.5.7: core-js@<2.6.8 is no longer maintained. Please, upgrade to core-js@3 or at least to actual version of core-js@2.
npm WARN deprecated joi@11.4.0: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).
npm WARN deprecated circular-json@0.3.3: CircularJSON is in maintenance only, flatted is its successor.
npm WARN deprecated kleur@2.0.2: Please upgrade to kleur@3 or migrate to 'ansi-colors' if you prefer the old syntax. Visit <https://github.com/lukeed/kleur/releases/tag/v3.0.0\> for migration path(s).
npm WARN deprecated flatten@1.0.2: I wrote this module a very long time ago; you should use something else.
npm WARN deprecated hoek@4.2.1: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).
npm WARN deprecated topo@2.0.2: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).
npm WARN deprecated left-pad@1.3.0: use String.prototype.padStart()



Tips för hur jag kan fixa det? https://github.com/theEmelie/me-react
Användarvisningsbild

efo

dbwebb

  • Inlägg: 386
  • Blev medlem: 15 aug 2016, 11:58
  • Ort: Rödeby

Re: npm dependencies?

Inlägg13 sep 2019, 07:33

Testa att köra kommandot npm audit, med det kommandot ser man vilka paket som utgör en säkerhetsrisk, sedan kan man köra npm audit fix, för att åtgärda vissa säkerhetshål.

theEmelie

html-guru

  • Inlägg: 62
  • Blev medlem: 02 sep 2018, 20:06

Re: npm dependencies?

Inlägg13 sep 2019, 13:24

Ah tack. Med hjälp utav
npm audit
fick jag fram att köra kommandot
npm install react-scripts@3.1.1
och det fungerar som det ska nu. Tack :D

Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 7 gäster