Uppdatera PHP till 7.2 för composer. Mac Mojave

  • Författare
  • Meddelande

Joll18

css-hackare

  • Inlägg: 26
  • Blev medlem: 07 sep 2018, 09:48

Uppdatera PHP till 7.2 för composer. Mac Mojave

Inlägg10 nov 2018, 12:45

För att jag skall kunna köra commandot "composer install" måste jag uppdatera till php7.2 (Ligger på 7.1.19 just nu)

Har kommit till att när jag kör phpInfo() i en .php fil så står det att min version är 7.2.9 men kör man php --version i terminalen får jag resultatet 7.1.19.
Samma som när jag kär composer install.

Har försökt uppdatera php via homebrew , lyckas hämta hem och "installera" men kan ej länka den. Får upp felet nedan när jag kör "brew link php"

"Linking /usr/local/Cellar/php/7.2.12...
Error: Could not symlink sbin/php-fpm
/usr/local/sbin is not writable. "

Längre än så kommer jag inte.

Mvh Johan

Joll18

css-hackare

  • Inlägg: 26
  • Blev medlem: 07 sep 2018, 09:48

Re: Uppdatera PHP till 7.2 för composer. Mac Mojave

Inlägg12 nov 2018, 11:50

Problem löst.
Följde denna guide
https://getgrav.org/blog/macos-mojave-apache-multiple-php-versions
om någon annan skulle ha liknande problem

Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 16 gäster