Bilder vissas inte

  • Författare
  • Meddelande

theEmelie

html-guru

  • Inlägg: 62
  • Blev medlem: 02 sep 2018, 20:06

Bilder vissas inte

Inlägg02 jan 2019, 20:58

När jag gör
dbwebb publishpure proj
Så vissas inte mina bilder på studentservern. Jag vet inte om det är mitt minne som har försvunnit under julen om det är något mer man behöver göra för att dom ska vissas?
Användarvisningsbild

lrc

troubleshooter

  • Inlägg: 391
  • Blev medlem: 11 aug 2016, 21:38
  • Ort: Östersund

Re: Bilder vissas inte

Inlägg02 jan 2019, 21:06

En vanlig orsak till sådana fel är att man har en skillnad i skiftläge mellan de faktiska filerna och sökvägarna till dem i koden, d.v.s. att en fil heter image.JPG på disk men länkas genom <img src="image.jpg">. Studentservern kör Linux som gör skillnad på dessa två saker, medan Windows inte gör det, så om man kör Windows lokalt missar man lätt detta fel om man inte vet om att titta efter det.

theEmelie

html-guru

  • Inlägg: 62
  • Blev medlem: 02 sep 2018, 20:06

Re: Bilder vissas inte

Inlägg02 jan 2019, 21:50

Testade ändra det, men det fungerar inte heller. Bilder blir som en liten liten fyrkantig ruta som kan klicka på, och då står det "[img.php] Source image is not a valid file, check the filename and that a matching file exists on the filesystem." Men det fungerar som det ska i localhost

theEmelie

html-guru

  • Inlägg: 62
  • Blev medlem: 02 sep 2018, 20:06

Re: Bilder vissas inte

Inlägg02 jan 2019, 22:21

Sen verkar det som om bilderna jag har från me/redovisning går att använda i me/proj även fast jag har tagit bort dom från img mappen i proj. Jätte förvirrad.
Användarvisningsbild

thulin

troubleshooter

  • Inlägg: 499
  • Blev medlem: 30 dec 2015, 15:33
  • Ort: Skurup

Re: Bilder vissas inte

Inlägg02 jan 2019, 22:25

Länka till sidan, så blir det lättare att felsöka och hjälpa dig.
/Thulin
Användarvisningsbild

lrc

troubleshooter

  • Inlägg: 391
  • Blev medlem: 11 aug 2016, 21:38
  • Ort: Östersund

Re: Bilder vissas inte

Inlägg02 jan 2019, 22:41

theEmelie skrev:Sen verkar det som om bilderna jag har från me/redovisning går att använda i me/proj även fast jag har tagit bort dom från img mappen i proj. Jätte förvirrad.

Detta tyder snarast på att du har en felaktig sökväg i din .htaccess, som pekar på me/redovisning istället för me/proj när det gäller CImage på studentservern. Kan det stämma?

theEmelie

html-guru

  • Inlägg: 62
  • Blev medlem: 02 sep 2018, 20:06

Re: Bilder vissas inte

Inlägg02 jan 2019, 22:45

lrc skrev:
theEmelie skrev:Sen verkar det som om bilderna jag har från me/redovisning går att använda i me/proj även fast jag har tagit bort dom från img mappen i proj. Jätte förvirrad.

Detta tyder snarast på att du har en felaktig sökväg i din .htaccess, som pekar på me/redovisning istället för me/proj när det gäller CImage på studentservern. Kan det stämma?


Stämmer bra :oops: Tack snälla :D

Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 11 gäster