Apache och namnbaserade virtuella hostar

  • Författare
  • Meddelande
Användarvisningsbild

emsa16

troubleshooter

  • Inlägg: 185
  • Blev medlem: 31 dec 2015, 10:29

Re: Apache och namnbaserade virtuella hostar

Inlägg10 sep 2016, 11:59

Jag har problem att visa innehållet i min vhosts/me.linux.se/htdocs som ligger på Debian-servern i min webbläsare på den lokala maskinen.

Jag får bara upp en "Welcome to XAMPP"-sida när jag kör alla dessa adresser på min lokala maskin (både i webbläsare och i lynx):
http://localhost:8080
http://127.0.0.1:8080
http://me.linux.se:8080

När jag kör http://me.linux.se på den virtuella maskinen (både i lynx och webbläsare) så fungerar allt som det ska. Däremot så leder http://localhost och http://127.0.0.1 (även dessa testade både i lynx och webbläsare) till innehållet i /var/www/html istället för innehållet i htdocs-mappen (har jag förstått rätt att även de borde leda till me.linux.se-sidan??)

Jag har letat i uppgifter och övningar och i forumet men har inte hittat något svar. Jag har gjort om allting i uppgiften flera gånger och startat om allt tänkbart.
Jag har igång Apache Web Server via XAMPP på min lokala maskin (på port 8080) och har igång Debian-servern i VirtualBox (med portforwarding uppsatt enligt instruktioner) och även där så är Apache2 Web Server igång.

Undrar också om lynx-kommandot som ska skärmdumpas i uppgiften ska köras lokalt eller på servern?
Användarvisningsbild

Allinrep

dbwebb

  • Inlägg: 1124
  • Blev medlem: 03 sep 2012, 09:19
  • Ort: Portugal (tillfälligt)

Re: Apache och namnbaserade virtuella hostar

Inlägg10 sep 2016, 23:44

Lösningen finns i det här avsnittet av övningen: Simulera ett hostnamn för servern

Du behöver ändra i filen /etc/hosts på din host (Mac), inte servern (Debian).
Användarvisningsbild

emsa16

troubleshooter

  • Inlägg: 185
  • Blev medlem: 31 dec 2015, 10:29

Re: Apache och namnbaserade virtuella hostar

Inlägg11 sep 2016, 11:17

Jag kanske missförstår instruktionerna. Det enda jag gjort är att jag har lagt in en rad i /etc/hosts:

127.0.0.1 linux.dbwebb.se (eller me.linux.se eller mysite.linux.se, beroende på uppgift)

Jag har lagt till detta i hosts-filen både på Debian och på Mac, men om jag tar bort raden från Debian-versionen så hittar inte webbläsaren på Debian längre sidan öht, medan det inte gör någon skillnad när jag kör webbläsaren på Mac-sidan, fortfarande bara XAMPP-sidan.

Såhär ser min hosts-fil ut på Mac-sidan:

##
# Host Database
#
# localhost is used to configure the loopback interface
# when the system is booting. Do not change this entry.
##
127.0.0.1 localhost
127.0.0.1 linux.dbwebb.se
127.0.0.1 me.linux.se
127.0.0.1 mysite.linux.se
255.255.255.255 broadcasthost
::1 localhost
fe80::1%lo0 localhost

127.0.0.1 Emils-MacBook-Pro.local # added by Apache Friends XAMPP
127.0.0.1 Emils-MBP # added by Apache Friends XAMPP



Och såhär ser hosts nu ut på Debian-sidan (har rensat ut de rader jag tidigare lagt till):

127.0.0.1 localhost
127.0.1.1 debian.mydomain.se debian

# The following lines are desirable for IPv6 capable hosts
::1 localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters



Har jag missat några instruktioner nånstans?
Användarvisningsbild

Allinrep

dbwebb

  • Inlägg: 1124
  • Blev medlem: 03 sep 2012, 09:19
  • Ort: Portugal (tillfälligt)

Re: Apache och namnbaserade virtuella hostar

Inlägg11 sep 2016, 21:12

emsa16 skrev:När jag kör http://me.linux.se på den virtuella maskinen (både i lynx och webbläsare) så fungerar allt som det ska. Däremot så leder http://localhost och http://127.0.0.1 (även dessa testade både i lynx och webbläsare) till innehållet i /var/www/html istället för innehållet i htdocs-mappen (har jag förstått rätt att även de borde leda till me.linux.se-sidan??)

Aha, jag läste lite för snabbt. Om http://me.linux.se fungerar både genom lynx (på servern) och webbläsaren (utanför VirtualBox) så har du gjort rätt. Det är det som står i me.linux.se.conf.

emsa16 skrev:Undrar också om lynx-kommandot som ska skärmdumpas i uppgiften ska köras lokalt eller på servern?

lynx ska köras på servern.
Användarvisningsbild

emsa16

troubleshooter

  • Inlägg: 185
  • Blev medlem: 31 dec 2015, 10:29

Re: Apache och namnbaserade virtuella hostar

Inlägg12 sep 2016, 17:35

Problemet är att jag inte får upp sidan i webbläsaren utan VirtualBox (dvs. på den lokala maskinen), utan endast en startsida för XAMPP.
Användarvisningsbild

mos

dbwebb

  • Inlägg: 11065
  • Blev medlem: 10 nov 2011, 09:52
  • Ort: Ronneby / Bankeryd

Re: Apache och namnbaserade virtuella hostar

Inlägg12 sep 2016, 17:53

Det låter som webbläsaren hittar till din XAMPP-installation på din lokala maskin.

Du vill vara säker på att allt fungerar på servern, innan du börjar testa/felsöka från din lokala maskin.
Logga in på servern, kör lynx - en webbsida från din apache virtuella host skall visas.

När du är 100 på att apache och den virtuella hosten fungerar på servern, då kan du testa från din lokala maskin.

Dubbelkolla att allt funkar på servern först?
...
..:
.... /mos
Användarvisningsbild

emsa16

troubleshooter

  • Inlägg: 185
  • Blev medlem: 31 dec 2015, 10:29

Re: Apache och namnbaserade virtuella hostar

Inlägg12 sep 2016, 21:29

Okej, såhär går det för mig. Var inloggad på servern hela tiden.

emil@debian:~$ lynx -> lynx.invisible-island.net

emil@debian:~$ lynx http://localhost -> Apache2 Debian Default Page (som hittas i /var/www/html)

emil@debian:~$ lynx http://127.0.0.1 -> Apache2 Debian Default Page (som hittas i /var/www/html)

Om raden 127.0.0.1 me.linux.se SAKNAS i /etc/hosts på servern:
emil@debian:~$ lynx http://me.linux.se -> "Unable to locate remote host me.linux.se."

Om raden 127.0.0.1 me.linux.se FINNS MED i /etc/hosts på servern:
emil@debian:~$ lynx http://me.linux.se -> innehållet i vhosts/me.linux.se/htdocs

Jag är osäker men hoppas att det var detta som jag ombads testa.
Användarvisningsbild

Allinrep

dbwebb

  • Inlägg: 1124
  • Blev medlem: 03 sep 2012, 09:19
  • Ort: Portugal (tillfälligt)

Re: Apache och namnbaserade virtuella hostar

Inlägg12 sep 2016, 21:41

Så här borde det vara.
Kod: Markera allt
emil@debian:~$ lynx http://localhost -> /var/www/html
emil@debian:~$ lynx http://127.0.0.1 -> /var/www/html
emil@debian:~$ lynx http://me.linux.se -> vhosts/me.linux.se/htdocs

I /etc/hosts förklarar du för din dator att om någon försöker ansluta till http://me.linux.se så ska datorn kolla lokalt, på det lokala ipnumret 127.0.0.1, inte fråga servrarna på internet. Om man köper en riktig domän behöver man inte ändra i /etc/hosts, det är bara något vi gör för att vi använder låtsasdomäner i kursen.

I filen me.linux.se.conf finns inställningar som talar om för Apache hur den ska reagera om någon försöker ansluta till http://me.linux.se. Där finns bara inställningar för http://me.linux.se, inte http://127.0.0.1 eller http://localhost, utan de två senare ska istället skickas till default-sidan i /var/www/html.

Då fungerar det alltså som tänkt från servern.

När du testar med din Mac behöver du kontrollera att http://me.linux.se finns i /etc/hosts-filen i Mac OS, annars kommer den tro att det är en riktig domän och leta efter den på internet istället för på din server.
Användarvisningsbild

emsa16

troubleshooter

  • Inlägg: 185
  • Blev medlem: 31 dec 2015, 10:29

Re: Apache och namnbaserade virtuella hostar

Inlägg13 sep 2016, 22:47

Okej, bra.

Jag har raden
127.0.0.1 me.linux.se
i hosts-filen, eller måste den ha http:// före? För när jag försöker med det så klagar lynx: "unable to locate remote host".

Men om det ska vara utan http:// så är jag tillbaka på ruta 1, att det som dyker upp är XAMPP:s startsida. Jag känner att det är något enkelt jag missar men jag fattar inte vad.

EDIT: Dvs, mitt problem är följande:

emsa16 skrev:Jag har problem att visa innehållet i min vhosts/me.linux.se/htdocs som ligger på Debian-servern i min webbläsare på den lokala maskinen.

Jag får bara upp en "Welcome to XAMPP"-sida när jag kör alla dessa adresser på min lokala maskin (både i webbläsare och i lynx):
http://localhost:8080
http://127.0.0.1:8080
http://me.linux.se:8080
Användarvisningsbild

mos

dbwebb

  • Inlägg: 11065
  • Blev medlem: 10 nov 2011, 09:52
  • Ort: Ronneby / Bankeryd

Re: Apache och namnbaserade virtuella hostar

Inlägg14 sep 2016, 14:30

emsa16 skrev:Jag har raden
127.0.0.1 me.linux.se
i hosts-filen, eller måste den ha http:// före? För när jag försöker med det så klagar lynx: "unable to locate remote host".


Ser bra ut.

Om du öppnar en webbläsare, eller lynx, mot http://127.0.0.1 så borde du få din lokala maskins webbserver, XAMPP kanske.

Om du öppnar webbläsaren mot http://me.linux.se så borde du få exakt samma resultat.

Men, förutsatt att du satt upp port forwardingen i Virtualbox till 8080, så skall du kunna öppna http://me.linux.se:8080 och komma till servern i Virtualbox.

Men, kanske har du en XAMPP som redan snurrar på port 8080 och krocker med din portforwardinställning i Virtualbox? Ändra då din port i virtualbox till 8081 och pröva att öppna webbläsaren till http://me.linux.se:8081 istället.

Berätta gärna vilka steg som fungerade och vilket som fallerade.
...
..:
.... /mos
Användarvisningsbild

emsa16

troubleshooter

  • Inlägg: 185
  • Blev medlem: 31 dec 2015, 10:29

Re: Apache och namnbaserade virtuella hostar

Inlägg14 sep 2016, 16:55

Äntligen funkar det! Nu hittar webbläsaren på den lokala maskinen till webbsidan på Debian-servern genom http://me.linux.se:8081 då jag ändrat port forwardingen i VirtualBox till port 8081.

Jag hade tidigare XAMPP satt till port 8080 och även satt VirtualBox att forwarda port 8080. Det var väl så det stod i instruktionerna? Så jag antod att det var man så man skulle göra? Kanske det vore bra att lägga in en kommentar om det, om det i framtiden finns studerande som är lika ny på detta som jag.

mos skrev:Om du öppnar en webbläsare, eller lynx, mot http://127.0.0.1 så borde du få din lokala maskins webbserver, XAMPP kanske.

Om du öppnar webbläsaren mot http://me.linux.se så borde du få exakt samma resultat.


Detta funkar däremot inte på den lokala maskinen. Webbläsaren säger genast att anslutningen misslyckades. Jag vet inte om det är superviktigt nu när det som behöver fungera gör det, men jag vill gärna förstå hur det är meningen att allt ska fungera.

En annan grej, i övningen Installera webbplatser med Apache Name-based Virtual Hosts står det såhär:

Nu kan jag komma åt den lokala maskinen via namnet istället. Adressen http://linux.dbwebb.se:8080 är numer samma som att skriva http://localhost:8080 eller http://127.0.0.1:8080. Det är precis detta som Apache tittar på när den identifierar den namnbaserade virtuella hosten.


Ovanstående tolkar jag som att alla dessa adresser ska leda till samma sida, men det är alltså så att linux.dbwebb.se:8080 leder till htdocs medan de andra leder var/www/html. Det är kanske uppenbart för någon som är lite mer insatt än jag i portar och servrar och ip-adresser att så inte är fallet, men utifall att det finns andra nybörjare på området så kanske detta stycke behöver förtydligas?
Användarvisningsbild

mos

dbwebb

  • Inlägg: 11065
  • Blev medlem: 10 nov 2011, 09:52
  • Ort: Ronneby / Bankeryd

Re: Apache och namnbaserade virtuella hostar

Inlägg14 sep 2016, 17:34

Kort svar om portarna. Stämmer att jag bör uppdatera och inte återanvända port 8080 i exemplet. Jag borde minst göra en notis om det.

Skall fixa.

emsa16 skrev:
mos skrev:Om du öppnar en webbläsare, eller lynx, mot http://127.0.0.1 så borde du få din lokala maskins webbserver, XAMPP kanske.

Om du öppnar webbläsaren mot http://me.linux.se så borde du få exakt samma resultat.


Detta funkar däremot inte på den lokala maskinen. Webbläsaren säger genast att anslutningen misslyckades. Jag vet inte om det är superviktigt nu när det som behöver fungera gör det, men jag vill gärna förstå hur det är meningen att allt ska fungera.


Det är inte superviktigt, men om du lägger till portnumret till din lokala XAMPP, dvs 8080, så bör det fungera som jag skrev. Så som jag skrev så gäller att din lokala webbserver snurrar på port 80, och det stämmer ju inte i ditt fall.


emsa16 skrev:En annan grej, i övningen Installera webbplatser med Apache Name-based Virtual Hosts står det såhär:

Nu kan jag komma åt den lokala maskinen via namnet istället. Adressen http://linux.dbwebb.se:8080 är numer samma som att skriva http://localhost:8080 eller http://127.0.0.1:8080. Det är precis detta som Apache tittar på när den identifierar den namnbaserade virtuella hosten.


Ovanstående tolkar jag som att alla dessa adresser ska leda till samma sida, men det är alltså så att linux.dbwebb.se:8080 leder till htdocs medan de andra leder var/www/html. Det är kanske uppenbart för någon som är lite mer insatt än jag i portar och servrar och ip-adresser att så inte är fallet, men utifall att det finns andra nybörjare på området så kanske detta stycke behöver förtydligas?


Hmm,ska kika även på det stycket i sitt sammanhang och se om det behöver uppdateras. Det som du kopierat in låter inte klockrent (kanske tom felaktigt).
...
..:
.... /mos
Användarvisningsbild

emsa16

troubleshooter

  • Inlägg: 185
  • Blev medlem: 31 dec 2015, 10:29

Re: Apache och namnbaserade virtuella hostar

Inlägg14 sep 2016, 17:54

När jag ändrar porten för Apache Web Server i XAMPP till 80 så då funkar sidorna som de borde, dvs. leder till XAMPP:s startsida. Det var bra att inse, nu är jag lite klokare iaf :)

vilc14

css-hackare

  • Inlägg: 24
  • Blev medlem: 31 aug 2016, 20:05

Re: Apache och namnbaserade virtuella hostar

Inlägg30 nov 2016, 08:42

Hej. Har suttit med detta i ett par dagar nu och får det fortfarande inte att fungera.

Jag kan helt enkelt inte ändra DocumentRoot. Oavsett vad jag skriver i config-filen, så skickar den mig alltid till www/html/.

(Får Syntax OK, med configtest).

har följt lite olika guider. Men inget fungerar verkar det som.
Användarvisningsbild

mos

dbwebb

  • Inlägg: 11065
  • Blev medlem: 10 nov 2011, 09:52
  • Ort: Ronneby / Bankeryd

Re: Apache och namnbaserade virtuella hostar

Inlägg01 dec 2016, 16:10

Om du går tillbaka till artikeln och gör det steg för steg:
https://dbwebb.se/kunskap/installera-we ... tual-hosts

Kan du säga hur långt allt verkar stämma och när det blir fel, stycke för stycke i texten?
...
..:
.... /mos
Användarvisningsbild

jeanette

html-guru

  • Inlägg: 65
  • Blev medlem: 22 aug 2016, 08:14

Re: Apache och namnbaserade virtuella hostar

Inlägg18 jan 2017, 17:39

Jag kommer inte heller åt webbplatsen via webbläsaren med hjälp av namnet. Den timar ut. När jag försöker köra den lokalt i VirtualBox med $ lynx linux.dbwebb.se så får jag "Forbidden. You don’t have permission to access / on this server".

När jag kollar errorfilen för den virtuella hosten står det ”client denied by server configuration: /home/jeag/vhosts/linux.dbwebb.se/htdocs/ vad betyder det?

http://localhost:8080 eller http://127.0.0.1:8080 funkar. Apache funkar. Config-filen ser ut exakt som i exemplet. Jag har uppdaterat hosts-filen. Jag har försökt följa alla steg. Vad har jag missat?

Tacksam för hjälp!
Användarvisningsbild

mos

dbwebb

  • Inlägg: 11065
  • Blev medlem: 10 nov 2011, 09:52
  • Ort: Ronneby / Bankeryd

Re: Apache och namnbaserade virtuella hostar

Inlägg18 jan 2017, 18:14

Du har felsökt enligt detta stycket?
https://dbwebb.se/kunskap/installera-we ... sts#felsok

Vilken blir utskriften från kommandona?

Hur ser din config-fil ut?

Apache kör som en annan användare än du själv, har du lagt DocumentRoot i din egen hemmakatalog, så behöver du se till att apache-användaren har tillgång dit. Ett enkelt sätt är att göra chmod 755 på alla kataloger, hela vägen ned till katalogen som är din DocumentRoot.
...
..:
.... /mos
Användarvisningsbild

jeanette

html-guru

  • Inlägg: 65
  • Blev medlem: 22 aug 2016, 08:14

Re: Apache och namnbaserade virtuella hostar

Inlägg19 jan 2017, 11:09

Ja, jag har gjort felsökningen, men jag vet ju inte riktigt vad jag letar efter...

Ja, jag har lagt DocumentRoot i min egen hemmakatalog (tror jag). Finns det ett alternativ till det? Rent principiellt, är det en bra grej att göra chmod755 på sin hemmakatalog och allt därunder (även om det inte spelar nån roll just nu)?

Gör jag rätt när jag skriver:
chmod 755 $HOME
chmod 755 /home/jeag
chmod 755 /home/jeag/vhosts
osv till htdocs?

För om det är rätt skrivet så funkar det ändå inte.

Så här ser configfilen ut:
configfil screenshot.png
Configfil
configfil screenshot.png (17.82 KiB) Visad 25354 gånger


Och så här ser det ut när jag kollar settings på virtualhosts:
VirtualBox_Debian_19_01_2017_09_49_07.png
Virtual hosts med settings
VirtualBox_Debian_19_01_2017_09_49_07.png (12.55 KiB) Visad 25354 gånger


sudo service apache2 status
ger en massa som jag inte begriper utom ”Active: active (running)”

apachectl configtest
ger ”Syntax ok”

sudo tail -f /var/log/apache2/error.log
ger ”caught SIGTERM, shutting down”

tail -f $HOME/vhosts/linux.dbwebb.se/error.log
ger ”client denied by server configuration: /home/jeag/vhosts/linux.dbwebb.se/htdocs/”

Så lost...
Användarvisningsbild

mos

dbwebb

  • Inlägg: 11065
  • Blev medlem: 10 nov 2011, 09:52
  • Ort: Ronneby / Bankeryd

Re: Apache och namnbaserade virtuella hostar

Inlägg19 jan 2017, 17:25

Pröva att se om användaren apache, den som normalt kör webbservern, har rättigheter att läsa alla kataloger hela vägen ned till DocumentRoot.

Din DocumentRoot är:
/home/jeag/vhosts/linux.dbwebb.se/htdocs

Kör följande kommando för att kontrollera vilka rättigheter katalogerna har, visa vilken utskrift du får.
Kod: Markera allt
ls -ld ~
ls -lR ~/vhosts


Vi vill se att det är rättigheter om 755 (-ish) på alla kataloger hela vägen ned till htdocs.
Det kan vara en felkälla.

Lägg även någon fil i din htdocs-katalog, tex en moped.html som innehåller "moped", bara för att testa. Den behöver rättigheter om 644.

Att ändra rättigheterna på detta sättet spelar ingen roll i sammanhanget, du har ingen information i din användare som du vill skydda. Om man läser på om hur rättigheter fungerar så kan man göra samma sak med färre rättigheter. Men det är överkurs i sammanhanget.
...
..:
.... /mos
Användarvisningsbild

jeanette

html-guru

  • Inlägg: 65
  • Blev medlem: 22 aug 2016, 08:14

Re: Apache och namnbaserade virtuella hostar

Inlägg23 jan 2017, 10:38

Så här ser det ut när jag gör ovan föreslagna kommandon. Vad är det jag letar efter?
rattigheter.png
rattigheter.png (20.89 KiB) Visad 25317 gånger


Om jag lägger en ny index-fil i me.linux.se/htdocs får jag heller inte upp den när jag kör lynx me.linux.se på den virtuella maskinen, bara apaches defaultsida.
Användarvisningsbild

Allinrep

dbwebb

  • Inlägg: 1124
  • Blev medlem: 03 sep 2012, 09:19
  • Ort: Portugal (tillfälligt)

Re: Apache och namnbaserade virtuella hostar

Inlägg23 jan 2017, 11:10

Det du letar efter när du kör ls -l är vilka rättigheter filerna har, alltså bokstäverna rwx i olika kombinationer (läs mer om användarrättigheter). Det viktiga är att det är r och x för alla tre användartyperna på alla kataloger, så det ser bra ut.

Däremot ser jag också att du inte har några filer alls i htdocs. Det kan vara svårt att se en webbsida om det inte finns någon webbsida. Prova att göra som mos skrev:
Lägg även någon fil i din htdocs-katalog, tex en moped.html som innehåller "moped", bara för att testa. Den behöver rättigheter om 644.


Får du samma resultat om du kör de här två kommandona? På min maskin blir det olika.
Kod: Markera allt
$ lynx linux.dbwebb.se
$ lynx http://linux.dbwebb.se
Användarvisningsbild

jeanette

html-guru

  • Inlägg: 65
  • Blev medlem: 22 aug 2016, 08:14

Re: Apache och namnbaserade virtuella hostar

Inlägg23 jan 2017, 11:32

Jag har lagt två filer i me.linux.se/htdocs nu (index.html och me.html), och framför dem står det bara -rw-r--r-- , är det det som är galet? Vad gör jag åt det?

Skärmavbild 2017-01-23 kl. 10.38.06.png
Skärmavbild 2017-01-23 kl. 10.38.06.png (51.47 KiB) Visad 25310 gånger


Och ja, jag får samma resultat av de två olika lynx-kommandona, apaches defaultsida.
Användarvisningsbild

mos

dbwebb

  • Inlägg: 11065
  • Blev medlem: 10 nov 2011, 09:52
  • Ort: Ronneby / Bankeryd

Re: Apache och namnbaserade virtuella hostar

Inlägg23 jan 2017, 12:33

Rättigheterna ser okey ut. Man vill se om det är rättigheterna som ger felmeddelandet.

Normalt är det svårt att felsöka (apache virtual hosts) när man inte har tillgång till hela systemet.

Den bästa taktiken att lösa liknande problem brukar helt enkelt vara att göra om från början med samma eller kanske en helt ny virtuell host. Hittills har man lyckats om man gör enligt artikeln, så sakerna i artikeln fungerar om man gör det i ordning.

Det går så mycket snabbare andra gången. Ännu snabbare tredje och fjärde gången.

Mitt råd är att du gör om från början, och ser om det går bättre.

Under tiden kan du kopiera in din config-fil för din virtuella host här, inte som bild utan som text, så kan jag testa den och se att den fungerar på min maskin.
...
..:
.... /mos
Användarvisningsbild

jeanette

html-guru

  • Inlägg: 65
  • Blev medlem: 22 aug 2016, 08:14

Re: Apache och namnbaserade virtuella hostar

Inlägg23 jan 2017, 16:04

Jag har gjort om det en gång utan lycka. Då gör jag det igen...

Men det spelar ingen roll att det när en gör apachectl -S (lista virtuella hostar med settings) står under www.me.linux.se "Main DocumentRoot: '/var/www/html' " ? Det är kanske inte den hosten den syftar på då?

Och visst kan inte flera webbplatser ligga på 127.0.0.1, utan jag måste ta bort den som redan låg där och skriva me.linux.se?

Här är configfilen:

<VirtualHost *:80>
ServerName http://www.me.linux.se
ServerAdmin webmaster@me.linux.se
DocumentRoot /home/jeag/vhosts/me.linux.se/htdocs

ErrorLog /home/jeag/vhosts/me.linux.se/error.log
CustomLog /home/jeag/vhosts/me.linux.se/access.log combined

<Directory />
Options Indexes FollowSymLinks
AllowOverride All
Order allow,deny
Allow from all
Require all granted
</Directory>
</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet
Användarvisningsbild

Allinrep

dbwebb

  • Inlägg: 1124
  • Blev medlem: 03 sep 2012, 09:19
  • Ort: Portugal (tillfälligt)

Re: Apache och namnbaserade virtuella hostar

Inlägg23 jan 2017, 16:36

jeanette skrev:Men det spelar ingen roll att det när en gör apachectl -S (lista virtuella hostar med settings) står under http://www.me.linux.se "Main DocumentRoot: '/var/www/html' " ? Det är kanske inte den hosten den syftar på då?

Main DocumentRoot är inte samma som den DocumentRoot du skriver in i configfilerna. Main-rooten används när något är fel med den du har ställt in.
jeanette skrev:Och visst kan inte flera webbplatser ligga på 127.0.0.1, utan jag måste ta bort den som redan låg där och skriva me.linux.se?

Vad menar du nu? Ingen av webbplatserna ska använda ett ipnummer, poängen med virtual hosts är att du ska kunna använda adresserna istället. Alla adresserna ska dessutom leda till samma ipnummer eftersom de ligger på samma maskin. Men 127.0.0.1 betyder alltid "den här maskinen" så den kan du bara ansluta till med en webbläsare på samma maskin, dvs lynx i den här övningen. Ska du ansluta från din host-dator istället, med t.ex. firefox, så fungerar inte 127.0.0.1 utan då måste du ta reda på vad debian-maskinen har för ipnummer först. Du kan kolla här Vad har datorn för ipnummer? för att se vilket ipnummer din Debian-maskin har.
Användarvisningsbild

jeanette

html-guru

  • Inlägg: 65
  • Blev medlem: 22 aug 2016, 08:14

Re: Apache och namnbaserade virtuella hostar

Inlägg24 jan 2017, 10:34

Jaha. På nåt sätt tror jag det funkar nu, på fjärde försöket. Kan det ha varit att jag missade ServerAlias i configfilen? Vem vet, vem vet...
Vad jag menade med ip-nummer var den här instruktionen:
sudo vim /etc/hosts
Följande rad lägger du till i filen.

127.0.0.1 linux.dbwebb.se


När jag öppnade den filen så fanns redan

127.0.0.1 localhost

där, jag trodde att jag var tvungen att ta bort den så att de inte krockade. Men det verkar ju inte spela någon roll.

Tack för ert oändliga tålamod!
Användarvisningsbild

Allinrep

dbwebb

  • Inlägg: 1124
  • Blev medlem: 03 sep 2012, 09:19
  • Ort: Portugal (tillfälligt)

Re: Apache och namnbaserade virtuella hostar

Inlägg24 jan 2017, 12:17

jeanette skrev:Vad jag menade med ip-nummer var den här instruktionen:
sudo vim /etc/hosts
Följande rad lägger du till i filen.

127.0.0.1 linux.dbwebb.se


När jag öppnade den filen så fanns redan

127.0.0.1 localhost

där, jag trodde att jag var tvungen att ta bort den så att de inte krockade. Men det verkar ju inte spela någon roll.

Många domäner kan peka på samma ipnummer. Sen är det upp till servern på det ipnumret att hålla koll på vilken domän som ska leda till vilken katalog, det du gör nu med virtual hosts.
Användarvisningsbild

mos

dbwebb

  • Inlägg: 11065
  • Blev medlem: 10 nov 2011, 09:52
  • Ort: Ronneby / Bankeryd

Re: Apache och namnbaserade virtuella hostar

Inlägg24 jan 2017, 13:59

Bra du löste det.

Fjärde gången gillt. Det är något jag själv kan relatera till.
...
..:
.... /mos

Scelus

php-programmerare

  • Inlägg: 42
  • Blev medlem: 13 jan 2015, 05:35
  • Ort: Katrineholm

Re: Apache och namnbaserade virtuella hostar

Inlägg01 feb 2017, 19:16

LÖST

Lösningen: Det behöver så klart vara boxens ip adress i windows .hosts inte 127.0.0.1
OBS: Fick det aldrig att fungera i Opera.

Har problem med att komma åt me.linux.se lokalt, igenom webbläsaren.

Har lagt till "127.0.0.1 me.linux.se" i C:\Windows\system32\drivers\etc\hosts

Har även lagt till 127.0.01 i min virtualbox /etc/hosts, följande kommando:

Kod: Markera allt
sudo lynx me.linux.se


Tar mig då till rätt plats (/home/scelus/vhosts/me.linux.se/htdocs/index.html).

----------------

Kod: Markera allt
sudo lynx localhost

Tar mig till apaches default sida i virtualboxen

Kod: Markera allt
sudo lynx me.linux.se

I Cygwin fungerar inte.

cygwin.png
cygwin.png (4.88 KiB) Visad 25210 gånger


----------------

Kod: Markera allt
apachectl -S


Ger följande resultat:
apachectl.png
apachectl.png (19.5 KiB) Visad 25211 gånger



Min config fil för me.linux.se:
conf.png
conf.png (9.41 KiB) Visad 25211 gånger


Samtliga error loggar är tomma.

makreng

troubleshooter

  • Inlägg: 231
  • Blev medlem: 23 aug 2016, 11:21

Re: Apache och namnbaserade virtuella hostar

Inlägg04 feb 2017, 12:32

Har också problem, trots att jag gjort om samma sak otaliga gånger. Försöker jag nå me.linux.se:8080 i webbläsaren så får jag bara "server not found" direkt. Testar jag linux.dbwebb.se:8080 så får jag timeout på servern. localhost:8080 fungerar.

Kör jag lynx me.linux.se får jag upp en sida som ser ut som default conf-filen? Men kör jag lynx linux.dbwebb.se så får jag upp en sida som ser ut såhär ungefär:
Index of/
[ICO]_Name Last modified Size Description
------------------------------------------------
-----------------------------------------------
Apache/2.4.10 (Debian) Server at linux.dbwebb.se Port 80

Kör jag ping me.linux.se får jag "64 bytes from localhost )127.0.0.1): icmp_seq=13 ttl=64 time=olika antal ms" om och om igen tills jag kör ctrl+c och avbryter.

Jag använder windows 10 så har ändrat i min dns genom sudo nano /etc/hosts så den ser ut såhär:
Kod: Markera allt
127.0.0.1      localhost
127.0.0.1      linux.dbwebb.se
127.0.0.1      me.linux.se
127.0.1.1      debian.mydomain.com   debian

# The following lines are desirable for IPv6 capable hosts
::1    localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

Men kollade också i min c:windows..etcetc-fil, och där finns det en annan lista med hosts? Tänkte kanske lägga in där med för säkerhets skull men kunde inte ändra i den, den försökte bara spara till en ny fil.

Så ja... vet inte riktigt hur jag ska göra för att lösa detta? Har gjort båda sidorna helt enligt instruktionerna men får olika resultat på dem ändå. Trippelkollat conf-filen och den ser exakt ut som exemplet i artikeln fast med mitt användarnamn då.

Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 5 gäster