Sida 1 av 1

FLASK CGI + valfel

InläggPostat: 20 jan 2019, 23:23
av knasenn
Hej,

Jag fick inte riktigt allt att fungera i CGI uppgiften.
Jag fick det inte att fungera lokalt. Ska man använda sig av appacheservern när man ska testa app.cgi/ ?
Jag får följande felmeddelande:
Kod: Markera allt
Server error!
The server encountered an internal error and was unable to complete your request.
Error message:
couldn't create child process: 720002: app.cgi
If you think this is a server error, please contact the webmaster.


Även om jag laddar upp filen till servern så fick jag det inte att fungera. Får följande felmeddelande:
Kod: Markera allt
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator at root@localhost to inform them of the time this error occurred, and the actions you performed just before this error.
More information about this error may be available in the server error log.



Jag noterade även att jag fick en del valideringsfel så som:
-UTF-8 Unicode text, with CRLF line term..
-HTML document, ASCII text, with CRLF ..
-m.m.


Andra som fått samma eller liknande?

Re: FLASK CGI + valfel

InläggPostat: 21 jan 2019, 08:50
av Zeldah
Ni behöver inte få CGI att fungera lokalt, det används bara för studentservern. Så om du inte verkligen vill få det att fungera lokalt hade jag inte lagt tid på det.

knasenn skrev:Även om jag laddar upp filen till servern så fick jag det inte att fungera. Får följande felmeddelande:

Kan du länka till din sida? Jag känner inte igen det felmeddelandet. Kolla först om nedanstående fel löser detta.

knasenn skrev:Jag noterade även att jag fick en del valideringsfel så som:
-UTF-8 Unicode text, with CRLF line term..
-HTML document, ASCII text, with CRLF ..
-m.m.

Du har fel radslut i filen, du ska ha LF.
om du öppnar filen i atom så nere i högra hörnet borde det vara en liten knapp där det står CLRF
klicka på den och ändra till LF

Re: FLASK CGI + valfel

InläggPostat: 22 jan 2019, 11:54
av knasenn
Zeldah skrev:Ni behöver inte få CGI att fungera lokalt, det används bara för studentservern. Så om du inte verkligen vill få det att fungera lokalt hade jag inte lagt tid på det.

knasenn skrev:Även om jag laddar upp filen till servern så fick jag det inte att fungera. Får följande felmeddelande:

Kan du länka till din sida? Jag känner inte igen det felmeddelandet. Kolla först om nedanstående fel löser detta.

knasenn skrev:Jag noterade även att jag fick en del valideringsfel så som:
-UTF-8 Unicode text, with CRLF line term..
-HTML document, ASCII text, with CRLF ..
-m.m.

Du har fel radslut i filen, du ska ha LF.
om du öppnar filen i atom så nere i högra hörnet borde det vara en liten knapp där det står CLRF
klicka på den och ändra till LF


Tack. Jag insåg att jag hade tolkat uppgiften fel så jag raderade de filerna som hade felmeddelandet du inte kände igen. Så nu är det *löst* :D

Resterade av valideringsfelen så gjorde det susen med att ändra till LF. Tack!