hello-web.cgi - 404 not found

  • Författare
  • Meddelande

valross

html-kodare

  • Inlägg: 11
  • Blev medlem: 12 jan 2015, 17:31

hello-web.cgi - 404 not found

Inlägg09 feb 2015, 10:48

http://www.student.bth.se/~erga15/dbweb ... lo-web.cgi

Har trots att jag validerat och publicerat inte fått igång .cgi-filen.
Den ligger ju i katalogen på servern och jag har kört chmod 755 på den.

Ändå får jag 404 not found.

But whyyyy?!
Användarvisningsbild

joaj14

troubleshooter

  • Inlägg: 457
  • Blev medlem: 19 aug 2014, 18:32
  • Ort: Helsingborg

Re: hello-web.cgi - 404 not found

Inlägg09 feb 2015, 10:55

valross skrev:Den ligger ju i katalogen på servern och jag har kört chmod 755 på den.


Hej,

Har du gjort detta på fel ställe? Du länkar hit http://www.student.bth.se/~erga15/dbwebb-kurser/python/me/kmom01/hello/ och här finns inte din fil.


Mvh,
Johan - fellow student

valross

html-kodare

  • Inlägg: 11
  • Blev medlem: 12 jan 2015, 17:31

Re: hello-web.cgi - 404 not found

Inlägg09 feb 2015, 10:59

joaj14 skrev:
valross skrev:Den ligger ju i katalogen på servern och jag har kört chmod 755 på den.


Hej,

Har du gjort detta på fel ställe? Du länkar hit http://www.student.bth.se/~erga15/dbwebb-kurser/python/me/kmom01/hello/ och här finns inte din fil.


Mvh,
Johan - fellow student


Jag såg det för en stund sedan och quadrupelkollade på servern med terminalen. Den finns där:
erga15@sweet: ls -la dbwebb-kurser/python/me/kmom01/hello/
total 16
drwxr-xr-x 2 erga15 20151 4096 feb 9 09:25 ./
drwxr-xr-x 4 erga15 20151 4096 feb 1 16:52 ../
-rwxr-xr-x 1 erga15 20151 0 feb 1 16:52 README.md*
-rwxr-xr-x 1 erga15 20151 930 feb 9 09:25 hello-web.cgi*
-rwxr-xr-x 1 erga15 20151 456 feb 4 08:05 hello.py*
Användarvisningsbild

joaj14

troubleshooter

  • Inlägg: 457
  • Blev medlem: 19 aug 2014, 18:32
  • Ort: Helsingborg

Re: hello-web.cgi - 404 not found

Inlägg09 feb 2015, 11:11

Hmmm,

Weird.

Jag tänkte att du kanske kollade i fel katalog så jag jämförde din listning med vad jag ser. Och både datum och storlek stämmer på de filerna som jag faktiskt ser. Vilket betyder att du sannolikt tittar i samma katalog som jag ser. Men jag ser som sagt inte filen.

Detta går över vad jag förstår. Maila kanske helpdesk på skolan och se om de kan förklara detta? Eller så vänta på att mos eller annan lärare ser tråden och ger det uppenbara svaret. :-)


Mvh,
Johan - fellow student
Användarvisningsbild

Sylvanas

dbwebb

  • Inlägg: 1133
  • Blev medlem: 16 nov 2011, 17:03
  • Ort: Karlskrona

Re: hello-web.cgi - 404 not found

Inlägg09 feb 2015, 11:23

Notera att du har två kataloger för kurserna: en direkt i hemkatalogen när du loggar in, och en i www-katalogen. Om du saknar en fil i www-katalogen (den publika) så har du glömt/missar/misslyckats med att göra bin/dbwebb publish kmom01 eller bin/dbwebb publish hello efter att du la till den filen. Kan det vara att det är detta som är fel?
Brain - "Are you pondering what I'm pondering?"
Pinky - "I think so, Brain, but there's still a bug stuck in here from last time."

valross

html-kodare

  • Inlägg: 11
  • Blev medlem: 12 jan 2015, 17:31

Re: hello-web.cgi - 404 not found

Inlägg09 feb 2015, 11:46

Sylvanas skrev:Notera att du har två kataloger för kurserna: en direkt i hemkatalogen när du loggar in, och en i www-katalogen. Om du saknar en fil i www-katalogen (den publika) så har du glömt/missar/misslyckats med att göra bin/dbwebb publish kmom01 eller bin/dbwebb publish hello efter att du la till den filen. Kan det vara att det är detta som är fel?


Ja det löste sig med att göra om publicering av kmom01.

Givetvis är det ju i www-mappen man ska kika (helt logiskt när du säger det =)

Nu funkar i alla fall uppladdningen korrekt, återstår bara att göra en helt korrekt cgi-fil då! =)
Tack Jane och Johan för svar!

Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 22 gäster