502 Bad gateway-fel med nginx-server och reverse proxy

  • Författare
  • Meddelande

MagnusLj

php-guru

  • Inlägg: 97
  • Blev medlem: 31 aug 2018, 14:57

502 Bad gateway-fel med nginx-server och reverse proxy

Inlägg07 sep 2019, 23:29

Edit: Det löste sig. Jag kunde inte komma på hur servern skulle hitta api:t i och med att det till skillnad mot frontend-sidans sites-available-fil inte fanns någon path till rooten i api:ts sites-available-fil. Till slut kom jag på att prova att ändra porten i app.js i api:t till 8333 med nano och det är tydligen så kopplingen görs, nu försvann Bad gateway-felet och apit:t fungerar på servern. Det hade nog varit enklare om man hade använt port 8333 från början istället för 1337 (om inte det skulle krocka med något lokalt). Som det är nu står det i instruktionerna för kursmomentet att api:t ligger och lyssnar på port 8333 när man har laddat upp det, men inte att man manuellt behöver ändra till den porten i api:t. I efterhand känns det ju rätt självklart att det ska vara så men jag/vi har inte jobbat med portar så mycket tidigare på utbildningen, förutom för localhost lokalt och jag fattar dem inte riktigt än, bra tillfälle nu att lära sig mer om hur de funkar.



Hej, det verkar inte finnas något subforum för jsramverk-kursen, så jag tänkte fråga här.

Jag håller på med kmom03 och har fått igång frontend-delen fint på nginx, med SSL och allt men api:t med reverse proxy funkar inte. Jag har nedanstående i min sites-available-fil:

server {
server_name me-api.dreamsofliden.me;

location /.well-known {
alias /var/www/me-api.dreamsofliden.me/html/.well-known;
}

location / {
proxy_pass http://localhost:8333;
proxy_http_version 1.1;
proxy_set_header Upgrade $http_upgrade;
proxy_set_header Connection 'upgrade';
proxy_set_header Host $host;
proxy_cache_bypass $http_upgrade;
}

listen 80;
}


och jag har gjort en symbolisk länk i sites-enabled. nginx -t ger inget felmeddelande.

Jag hade skaffat SSL-certifikat men har nu testat att köra utan det för att se om det fungerade då men det är samma sak. I nginx fellogg får jag felet

[error] 19303#19303: *13 connect() failed (111: Connection refused) while connecting to upstream, client: 213.89.124.38, server: me-api.dreamsofliden.me, request: "GET / HTTP/1.1", upstream: "http://127.0.0.1:8333/", host: "me-api.dreamsofliden.me"


oavsett om jag har satt igång api:t med npm run production eller inte.

Tacksam för tips!

Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 18 gäster