Problem med att pusha till github

  • Författare
  • Meddelande

Danne97

php-programmerare

  • Inlägg: 41
  • Blev medlem: 29 aug 2017, 17:31

Problem med att pusha till github

Inlägg20 nov 2017, 13:22

Jag följer stegen från https://dbwebb.se/kunskap/bygg-me-sida- ... pla-github

Jag skrev kommandot:
git remote add origin https://github.com/Danne97/Anax-Flat.git

Sen kom jag på att jag ville ha ssh nyckel och inte https, så jag skrev kommandot:
git remote add origin git@github.com:Danne97/Anax-Flat.git

Då fick jag felmeddelandet:
fatal: remote origin already exists.

Efter det skrev jag:
git push -u origin master

Och får felmeddelandet:
error: src refspec master does not match any.
error: failed to push some refs to 'https://github.com/Danne97/Anax-Flat.git'
Användarvisningsbild

mos

dbwebb

  • Inlägg: 11177
  • Blev medlem: 10 nov 2011, 09:52
  • Ort: Ronneby / Bankeryd

Re: Problem med att pusha till github

Inlägg20 nov 2017, 13:35

Du har redan lagt till en remote så du behöver byta ut den mot en annan.

Pröva: https://help.github.com/articles/changi ... ote-s-url/
...
..:
.... /mos

Danne97

php-programmerare

  • Inlägg: 41
  • Blev medlem: 29 aug 2017, 17:31

Re: Problem med att pusha till github

Inlägg20 nov 2017, 14:00

Testade att göra med både
$ git remote set-url origin git@github.com:Danne97/Anax-Flat.git
och
$ git remote set-url origin https://github.com/Danne97/Anax-Flat.git

Och det fungerar att byta mellan ssh och https.
Men jag får fortfarande samma fel när jag ska pusha.
Användarvisningsbild

mos

dbwebb

  • Inlägg: 11177
  • Blev medlem: 10 nov 2011, 09:52
  • Ort: Ronneby / Bankeryd

Re: Problem med att pusha till github

Inlägg20 nov 2017, 14:36

Har du lagt till filer och committat dem?
https://stackoverflow.com/a/7572252/341137
...
..:
.... /mos

Danne97

php-programmerare

  • Inlägg: 41
  • Blev medlem: 29 aug 2017, 17:31

Re: Problem med att pusha till github

Inlägg20 nov 2017, 14:51

Nu fungerar det.
Jag gjorde en commit tidigare men fick ett felmeddelande som jag inte upptäckte.
Så jag commita en gång till och sedan pushade jag och nu fungerar det som det ska.

Tack för hjälpen

Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 16 gäster