problem med svenska tecken

  • Författare
  • Meddelande

pile16

javascriptare

  • Inlägg: 35
  • Blev medlem: 18 jan 2016, 10:26

problem med svenska tecken

Inlägg20 jan 2016, 15:53

Jag har försökt hitta felet för att åtgärda problemet med svenska tecken men lyckades ej.
Har också även googlat på nätet.

Misstänker att det kan vara strul med xamapp eftersom det är ju där som genererar kod men var exakt kan man ändra config.txt för apache?

Kanske kan ni hjälpa mig på något sätt.

Bifogar en bild.

Kod: Markera allt
<!doctype html>
<html lang="sv">
<head>
<meta charset="utf-8"/>
    <title>Me-sidan</title>
        <link rel="stylesheet" href="css/style.css">
   <link rel='shortcut icon' href='img/he.ico'/>
</head>
Bilagor
letters.PNG
letters.PNG (174.8 KiB) Visad 2259 gånger
Användarvisningsbild

ceruza

git-maestro

  • Inlägg: 123
  • Blev medlem: 31 aug 2015, 17:14

Re: problem med svenska tecken

Inlägg20 jan 2016, 16:13

Kolla om den editor du använder är inställd på att spara filerna i UTF-8.
Om dina PHP-filer är sparade i något annat än UTF-8, kommer du få frågetecken. Din HTML-kod ovan säger åt webbläsaren att det är UTF-8 som du skickar, men om det inte stämmer får du frågetecken.

pile16

javascriptare

  • Inlägg: 35
  • Blev medlem: 18 jan 2016, 10:26

Re: problem med svenska tecken

Inlägg20 jan 2016, 16:18

Använder notepad++ som editor.

Fortfarande samma problem som förr. Fortfarande frågetecken...
Bilagor
ed_utf8.PNG
ed_utf8.PNG (11.12 KiB) Visad 2251 gånger
Användarvisningsbild

thulin

troubleshooter

  • Inlägg: 514
  • Blev medlem: 30 dec 2015, 15:33
  • Ort: Skurup

Re: problem med svenska tecken

Inlägg20 jan 2016, 16:22

Det där säger bara hur NYA dokument ska sparas, ej hur ditt nuvarande dokument ser ut.
Ändra teckenkodning under "Encoding" i menyerna

Edit: Nuvarande teckenkodning ses nere till höger i statusraden, gissningsvis har du ANSI istället för UTF
/Thulin
Användarvisningsbild

ceruza

git-maestro

  • Inlägg: 123
  • Blev medlem: 31 aug 2015, 17:14

Re: problem med svenska tecken

Inlägg20 jan 2016, 16:28

Sedan kan jag också tipsa om unix radbrytning, annars kommer dbwebbs validatorer klaga!

pile16

javascriptare

  • Inlägg: 35
  • Blev medlem: 18 jan 2016, 10:26

Re: problem med svenska tecken

Inlägg20 jan 2016, 16:40

Thulin, helt riktigt det där om ANSI. Vet inte hur och varför det ändrades till ANSI trots jag har kodat flera gånger. Måste ha bytts småningom.

Ceruza, unix radbrytning. Tusen tack för tipset. Visste inte att dbwebbs validatorer är så petiga noggranna.
Användarvisningsbild

thulin

troubleshooter

  • Inlägg: 514
  • Blev medlem: 30 dec 2015, 15:33
  • Ort: Skurup

Re: problem med svenska tecken

Inlägg20 jan 2016, 16:42

Beror lite på hur man skapar filerna.
Om man skapar en ny fil i windows, eller via cmd/terminal eller om du kopierar någon annan fil. Det bästa är att hålla koll på det i statusraden, där ser du ju även vilken typ av radbrytning ditt nuvarande dokument har.
/Thulin
Användarvisningsbild

mos

dbwebb

  • Inlägg: 11063
  • Blev medlem: 10 nov 2011, 09:52
  • Ort: Ronneby / Bankeryd

Re: problem med svenska tecken

Inlägg20 jan 2016, 16:58

Använd UTF-8 NO BOM, istället för bara UTF-8, annars blir det bekymmer.
...
..:
.... /mos

pile16

javascriptare

  • Inlägg: 35
  • Blev medlem: 18 jan 2016, 10:26

Re: problem med svenska tecken

Inlägg20 jan 2016, 17:50

mos skrev:Använd UTF-8 NO BOM, istället för bara UTF-8, annars blir det bekymmer.

Ja, helt riktigt! Hade bekymmer när jag använde bara UTF-8 och ingen favicon syns i flik, så jag testade med UTF-8 no bom och favicon återställde igen i flik.

Nice ny erfarenhet!

Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 15 gäster