Problem med Git i Cygwin

  • Författare
  • Meddelande

Sherpas

webbsurfare

  • Inlägg: 6
  • Blev medlem: 18 jan 2016, 21:49

Problem med Git i Cygwin

Inlägg19 jan 2016, 11:39

Hej,

Jag håller på att försöka komma igång med htmlphp kursen.

Har installerat Cygwin och kört dbwebb kommandon vilket gick bra. Har kommit till då jag ska klona git repot, kör jag kommandot dbwebb clone får jag en lista på repon men då jag skriver dbwebb clone htmlphp får jag dom här felen:
$ dbwebb clone htmlphp
Cloning course-repo for 'htmlphp' from 'https://github.com/mosbth/htmlphp'.
bash: git: kommandot finns inte
FAILED to clone course repo.

För att felsöka skrev jag dbwebb check vilket bland annat visar det här:
git: Command git not found.

Vilket får mig att tro att den inte hittar min git installation...

Jag har git installerat sen tidigare, valde då att köra Git Bash vilket jag tror kan vara problemet eftersom jag då ej kan köra git kommandon från andra terminaler.

Innebär det här att jag måste installera om git för att köra från Cygwin terminalen eller kan jag klona repon från min git bash terminal utan att det skapar problem?

Har redan klonat repon tidigare i git bash terminalen så vet hur det fungerar.. skulle helst fortsätta så om det går! :)
Användarvisningsbild

thulin

troubleshooter

  • Inlägg: 514
  • Blev medlem: 30 dec 2015, 15:33
  • Ort: Skurup

Re: Problem med Git i Cygwin

Inlägg19 jan 2016, 11:43

Kolla in maaa16's problem i denna tråden viewtopic.php?f=23&t=4015&start=60, samt mina (thulin) och mos's tips på samma problem!
/Thulin

Sherpas

webbsurfare

  • Inlägg: 6
  • Blev medlem: 18 jan 2016, 21:49

Re: Problem med Git i Cygwin

Inlägg19 jan 2016, 12:07

Ok tack så mycket :) , det fungerade efter jag installerat git i Cygwin.. nu har jag 2 git installationer så hoppas dom inte krockar på något sätt. Än så länge verkar det fungera i alla fall!
Online
Användarvisningsbild

mos

dbwebb

  • Inlägg: 11065
  • Blev medlem: 10 nov 2011, 09:52
  • Ort: Ronneby / Bankeryd

Re: Problem med Git i Cygwin

Inlägg19 jan 2016, 16:39

Det bör funka utan krångel (med två installationer av Git).
...
..:
.... /mos
Användarvisningsbild

thulin

troubleshooter

  • Inlägg: 514
  • Blev medlem: 30 dec 2015, 15:33
  • Ort: Skurup

Re: Problem med Git i Cygwin

Inlägg19 jan 2016, 16:41

och som jag och mos snackade om i chat (och i annan del av forumet?) så är troligtvis ditt problem att inte git.exe (eller rättare sagt mappen där den ligger) finns med i systemvariablen $PATH
/Thulin

Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 14 gäster