Atom gillar inte php. Vf?

  • Författare
  • Meddelande

guda15

php-programmerare

  • Inlägg: 40
  • Blev medlem: 31 aug 2015, 15:23

Atom gillar inte php. Vf?

Inlägg02 okt 2015, 15:54

Ngn som kan lära mig vad som är orsaken o hur jag åtgärdar detta fel?

Jag ställer mig i en ny mapp på Dropbox, skapar däri en fil m filändelse *.php.

Ifrån samma mapp öppnar jag därefter upp Atom o får genast följande felmeddelande då jag öppnar upp den tomma php-filen:

"Error: 'php' is not recognized as an internal or external command, operable program or batch file.
Error: 'php' is not recognized as an internal or external command,
operable program or batch file.
at exit (C:\Users\Mamsen\.atom\packages\linter-pylint\node_modules\atom-linter\lib\helpers.coffee:32:24)
at triggerExitCallback (C:\Users\Mamsen\AppData\Local\atom\app-1.0.19\resources\app.asar\src\buffered-process.js:213:47)
at ChildProcess.<anonymous> (C:\Users\Mamsen\AppData\Local\atom\app-1.0.19\resources\app.asar\src\buffered-process.js:235:18)
at emitTwo (events.js:87:13)
at ChildProcess.emit (events.js:172:7)
at Process.ChildProcess._handle.onexit (internal/child_process.js:200:12)"
Användarvisningsbild

mos

dbwebb

  • Inlägg: 11063
  • Blev medlem: 10 nov 2011, 09:52
  • Ort: Ronneby / Bankeryd

Re: Atom gillar inte php. Vf?

Inlägg02 okt 2015, 16:12

Kolla om du installerat en plugin/paket som använder sig av php. Tex linter-php, linter-phpcs, linter-phpmd. Disabla den om du inte har installerat så att kommandot php finns i din path/sökväg.
...
..:
.... /mos

guda15

php-programmerare

  • Inlägg: 40
  • Blev medlem: 31 aug 2015, 15:23

Re: Atom gillar inte php. Vf?

Inlägg03 okt 2015, 06:23

Helt korrekt. Atom klagade inte förut, dvs innan jag lyckades installera samtliga pkt, som finns i teckensträngen i installationsanvisningarna. Däremot färgmärktes inte min kod pss som den du uppvisade via Youtube -klippen.

Vf skulle paketen installeras, om jag ska disabla dem nu? Är tacksam för en förklaring, så att jag förstår sammanhanget.

guda15

php-programmerare

  • Inlägg: 40
  • Blev medlem: 31 aug 2015, 15:23

Re: Atom gillar inte php. Vf?

Inlägg04 okt 2015, 19:20

Förstår fortfarande inte din kommentar Mos. Behöver hjälp m att komma vidare.

Idag uppger Atom behov av uppdat av 9 pkt, gör detta. Får följande fel. Vad innebär det? (Har detta måhända samröre m ovanstående strul?)

Hur finner jag o åtgärdar modul 'grim'?

/Birgitta

[Enter steps to reproduce below:]

1. ...
2. ...

**Atom Version**: 1.0.19
**System**: Microsoft Windows 10 Home
**Thrown From**: [linter](https://github.com/atom-community/linter) package, v1.8.0


### Stack Trace

Failed to activate the linter package

```
At Cannot find module 'grim'

Error: Cannot find module 'grim'
at Module._resolveFilename (module.js:334:15)
at Function.Module._resolveFilename (C:\Users\Mamsen\AppData\Local\atom\app-1.0.19\resources\app.asar\src\module-cache.js:383:52)
at Function.Module._load (module.js:284:25)
at Module.require (module.js:363:17)
at require (module.js:382:17)
at Object.module.exports.activate (C:\Users\Mamsen\.atom\packages\linter\lib\main.coffee:77:14)
at Package.module.exports.Package.activateNow (C:\Users\Mamsen\AppData\Local\atom\app-1.0.19\resources\app.asar\src\package.js:245:19)
at C:\Users\Mamsen\AppData\Local\atom\app-1.0.19\resources\app.asar\src\package.js:226:30
at Package.module.exports.Package.measure (C:\Users\Mamsen\AppData\Local\atom\app-1.0.19\resources\app.asar\src\package.js:169:15)
at Package.module.exports.Package.activate (C:\Users\Mamsen\AppData\Local\atom\app-1.0.19\resources\app.asar\src\package.js:218:14)
```

### Commands

```
-3:40.7.0 pane:close (atom-text-editor.editor)
-3:03.4.0 core:paste (atom-text-editor.editor.is-focused)
-2:56.7.0 editor:newline (atom-text-editor.editor.is-focused)
-2:35.1.0 line-ending-converter:convert-to-unix-format (atom-text-editor.editor.is-focused)
-2:23 grammar-selector:show (atom-text-editor.editor)
-1:58.2.0 settings-view:check-for-package-updates (atom-workspace.workspace.scrollbars-visible-always.theme-one-dark-syntax.theme-one-dark-ui)
```

### Config

```json
{
"core": {
"followSymlinks": false
}
}
```

### Installed Packages

```coffee
# User
block-travel, v1.0.2
line-ending-converter, v1.3.2
linter, v1.8.0
linter-csslint, v1.0.7
linter-htmlhint, v0.1.1
linter-jshint, v1.2.1
linter-less, v2.1.0
linter-pep8, v1.0.1
linter-php, v1.0.5
linter-phpcs, v1.1.4
linter-phpmd, v1.2.1
linter-pylint, v1.0.2
linter-shellcheck, v1.0.2
linter-xmllint, v0.0.7
remote-edit, v1.8.21

# Dev
No dev packages
```
Användarvisningsbild

mos

dbwebb

  • Inlägg: 11063
  • Blev medlem: 10 nov 2011, 09:52
  • Ort: Ronneby / Bankeryd

Re: Atom gillar inte php. Vf?

Inlägg05 okt 2015, 16:23

guda15 skrev:Vf skulle paketen installeras, om jag ska disabla dem nu? Är tacksam för en förklaring, så att jag förstår sammanhanget.


I guiden så visar jag hur man kan installera paket via kommandlineutilitien.

Det jag inte säger, vilket jag nu skall uppdatera artikeln med, är att varje paket kan vara beroende av externa verktyg.

linter-php är beroende av att programmet php finns i sökvägen.
linter-phpmd är beroende av att programmet phpmd finns i sökvägen.
linter-phpcs är beroende av att programmet phpcs finns i sökvägen.

För att de pluginen skall fungera så behöver man alltså fler saker på sin miljö. Men det är en egen historia hur man installerar dem och det kan upplevas lite krävande att få det att fungera.

Jag skall förtydliga artikeln med en not om att paketen har externa beroenden. Det är alltså inte riktigt så lätt att få in dessa valideringsverktyg. Det kräver lite extra arbete och för tillfället har jag ingen guide på hur man fixar det.

När du nu får liknande fel, gå då in och disabla paketet. Det är den enkla vägen för tillfället.
...
..:
.... /mos

guda15

php-programmerare

  • Inlägg: 40
  • Blev medlem: 31 aug 2015, 15:23

Re: Atom gillar inte php. Vf?

Inlägg09 okt 2015, 14:13

Du har iofs skrivit "Notera att varje paket kan vara beroende av att ditt system har relaterade programvaror installerade. Du bör därför installera varje paket för sig så att du har koll på eventuella externa beroenden."

..men det är ju inte tillräckligt för en som är lika grön som jag.

Jättebra att du förtydligar o utvidgar installationstipsen!

Jag behöver nu genast få veta vilket kommando som jag ska använda. Det finns inget 'disable'. Där finns 'deinstall', 'delete', 'uninstall' m fl

PS
Det var inte heller ens självklart för mig att jag skulle göra detta via kommandotolken o att syntaxen är apm <command> linter-xx (Skriv dettta oxå i klartext i anvisningarna, så slipper andra ägna lika mkt tid åt dylikt strul som jag gjort.)

guda15

php-programmerare

  • Inlägg: 40
  • Blev medlem: 31 aug 2015, 15:23

Re: Atom gillar inte php. Vf?

Inlägg09 okt 2015, 14:52

apm uninstall linter-xx

ser ut att funka.
Användarvisningsbild

mos

dbwebb

  • Inlägg: 11063
  • Blev medlem: 10 nov 2011, 09:52
  • Ort: Ronneby / Bankeryd

Re: Atom gillar inte php. Vf?

Inlägg09 okt 2015, 14:56

guda15 skrev:Du har iofs skrivit "Notera att varje paket kan vara beroende av att ditt system har relaterade programvaror installerade. Du bör därför installera varje paket för sig så att du har koll på eventuella externa beroenden."

..men det är ju inte tillräckligt för en som är lika grön som jag.

Jättebra att du förtydligar o utvidgar installationstipsen!


Precis den skrivelsen kom till efter dina bekymmer, så bra du sa till. Den fanns inte från början.

Ser ut som du lyckas ta bort dem, annars säg till.
...
..:
.... /mos

guda15

php-programmerare

  • Inlägg: 40
  • Blev medlem: 31 aug 2015, 15:23

Re: Atom gillar inte php. Vf?

Inlägg09 okt 2015, 19:41

Jag trodde det var jag som hade missat att läsa det textstycket, nåväl jag hade förmodligen inte blivit värst mkt klokare på det - utan behövde oxå få den info du skrivit här om att disabla. Lr då ännu hellre att du explicit skriver ut hela kommandoraden o talar om att detta ska göras via kommandotolken; apm uninstall linter-xx

Tack, nu har jag fått igång denna bit på båda mina maskiner. Ser fram emot att börja m det som kursen egentligen handlar om nu:-P

Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 14 gäster