Gravatar går inte över https

  • Författare
  • Meddelande
Användarvisningsbild

Allinrep

dbwebb

  • Inlägg: 1124
  • Blev medlem: 03 sep 2012, 09:19
  • Ort: Portugal (tillfälligt)

Gravatar går inte över https

Inlägg07 maj 2017, 23:04

Ända sedan uppgraderingen till https sommaren 2016 har jag fått klagomål av min webbläsare att sidan inte är helt säker. Orsaken är att min avatar hämtas osäkert från Gravatar.

Nu har jag äntligen lyckats få en https-gravatar på forumet. När jag går till min kontrollpanel och "Ändra visningsbild" så hämtas den nuvarande bilden från:
https://secure.gravatar.com/avatar/f902f74bd5a291d33ba4eac7845b52dc.jpg

Problemet är nu den lilla minivarianten uppe i hörnet, den verkar hårdkodad till http://www.gravatar istället för https://secure.gravatar.

Finns forumkoden publikt någonstans så att jag kan fixa det?
Användarvisningsbild

mos

dbwebb

  • Inlägg: 11180
  • Blev medlem: 10 nov 2011, 09:52
  • Ort: Ronneby / Bankeryd

Re: Gravatar går inte över https

Inlägg08 maj 2017, 10:18

Forumkoden ligger på Bitbucket (ej publik).

Men den delen som fixar länken uppe till höger och som nu är http (av någon anledning) skapas i denna vyn i vendor/mos/anax.
https://github.com/mosbth/anax/blob/mas ... bb.tpl.php
...
..:
.... /mos
Användarvisningsbild

thulin

troubleshooter

  • Inlägg: 514
  • Blev medlem: 30 dec 2015, 15:33
  • Ort: Skurup

Re: Gravatar går inte över https

Inlägg08 maj 2017, 13:26

Det här har även jag kollat på lite då och då, finns ju en issue på GitHub: https://github.com/dbwebb-se/website/issues/7
/Thulin

Vilka är online

Användare som besöker denna kategori: Inga registrerade användare och 11 gäster